Sunday, August 26, 2007

Linux works just fine, thank you very much!

In the last posting I made a few snide comments about Vista's documented network (un)performance while Vista was playing back something as simple as an MP3. I found a moment this evening to set up an extremely simple experiment where I streamed a movie and played an MP3 at the same time on europa. The movie, ripped earlier this year from a DVD using VLC, was streamed from an Ubuntu 7.04 system (rhea) while the MP3, ripped from my CD of the movie sound track using K3B, was played from a local file. The two multimedia files used in this test were:
  • Movie: "Ghost Rider", MPEG-4, 720 x 480, two channel audio, 1.2 GiB size
  • Song: "Son of Man", sung by Phil Collins from the Disney movie "Tarzan", MP3 320 KiB sampling
The two systems used in this test were:
  • Europa, a four-year-old 32-bit single core Athlon XP 3200+ system with an ATI 9700 Pro and 1GiB of DRAM running openSuse 10.2, and
  • Rhea, a three-year-old 32-bit single core Athlon XP 2500+ system with an nVidia 7600 video card and 512 MiB of DRAM running Ubuntu 7.04.
To run this very simple test I used a second system, rhea, to host the movie. Rhea and europa (running openSuse 10.2) are connected together with a Netgear FS605 five port ethernet switch. Both are connected into the switch with 100MiB ethernet. Rhea shares a folder with movies I've ripped via SMB. Europa sees this particular folder and mounts it. The test consisted of playing Ghost Rider via Kaffeine on europa from rhea across the simple network. I let the movie play for a while, turned down the sound on the movie, then played the MP3 with RealPlayer 10. I listened to the entire song, and heard no pops or distortion in its playback. The screen shot below shows the test as it was underway.

Again, I stress that this is no "real" test. No hard numbers (specifically throughput) were captured, nor was the experiment repeated multiple times. I simply ran the Gnome System Monitor at some point well after the movie started and watched the processor and network performance while everything was running. You'll note that somewhere between 40% and 50% of europa's processor is being used. I noticed that playing the MP3 had little or no noticeable effect, at least by observing System Monitor. Nor did the MP3 have any effect on the movie; no frames dropped, no stutter, or any audio distortions. It seemed to be pretty much all due to video playback. Looking at System Monitor and just playing the MP3 showed such a low usage that it was indistinguishable from an idle system.

These aren't state of the art systems by any stretch any more, and there is no way either could run Vista. But with contemporary Linux distributions, they are more than capable of soldiering on. Here is a screen capture System Monitor from rhea.

You can see at the bottom how rhea was pumping out the movie across its network connection until I stopped the movie. But note the processor utilization at the top. Processor utilization was nearly flat at 6% the entire time.

For development or consumer use, of what use is Windows any longer?

No comments:

Post a Comment

All comments are checked. Comment SPAM will be blocked and deleted.

Note: Only a member of this blog may post a comment.